关注网络资源
用心与您分享

CentOS系统手动安装最新版内核headers教程

提示:如果官网是英文页面,建议使用谷歌浏览器能同步翻译页面。点击下载【谷歌浏览器最新绿色便携版】
投稿QQ:768187171、投稿邮箱:768187171@qq.com,博文推送Telegram频道:https://t.me/wn789

此文章转自@秋水逸冰。之前蜗牛CentOS 6/7系统手动升级最新内核后开启Google BBR详细教程文章中介绍了如何手动升级CentOS 6/7系统最新内核并启用BBR,有个时候我们可以能需要把CentOS系统的内核升级到最新版的headers,于是蜗牛789转载了一个关于手动安装最新版内核headers的教程。

执行以下命令

yum --enablerepo=elrepo-kernel -y install kernel-ml-headers

根据 CentOS 版本的不同,此时一般会出现类似于以下的错误提示:

Error: kernel-ml-headers conflicts with kernel-headers-2.6.32-696.20.1.el6.x86_64
Error: kernel-ml-headers conflicts with kernel-headers-3.10.0-693.17.1.el7.x86_64

因此需要先卸载原版内核 headers ,然后再安装最新版内核 headers。执行命令:

yum remove kernel-headers

确认无误后,输入 y,回车开始卸载。注意,有时候这么操作还会卸载一些对内核 headers 依赖的安装包,比如 gcc、gcc-c++ 之类的。不过不要紧,我们可以在安装完最新版内核 headers 后再重新安装回来即可。
卸载完成后,再次执行上面给出的安装命令。

yum --enablerepo=elrepo-kernel -y install kernel-ml-headers

成功安装后,再把那些之前对内核 headers 依赖的安装包,比如 gcc、gcc-c++ 之类的再安装一次即可。

未经允许不得转载:蜗牛789 » CentOS系统手动安装最新版内核headers教程
支付宝扫码打赏 微信扫码打赏

如果文章对您有帮助,欢迎点击上方按钮打赏蜗牛

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址